Samstag, 8. März 2008

Neue Solstat-Version

Dr. Guido Janzen hat eine neue Solstat-Version veröffentlicht. Details hier.

Kommentare:

Guido (Brilon) hat gesagt…

52 Downloads in den gerade mal 36 Stunden bis gestern Abend, obwohl ich gar keine große Werbung gemacht habe...

Erwin (Wildeck) hat gesagt…

Hallo Guido,
gut gelungen. Die Änderungen gefallen mir sehr gut, damit ist auch meine Statistik schnell gemacht.

Danke für das schöne Programm

Gruß, Erwin

Dirk (BreNor) hat gesagt…

Hallo Guido,
auch Ich finde deine Änderungen sehr gut.

Leider bekomme ich nicht alle Datenkanäle in die Legende, mache ich da was falsch, oder ist dies beabsichtigt?

Mit der Himmelsrichtung und den Einfallswinkel 1-5 komme ich nicht klar. Du hast nur eine Himmelsrichtung und 5 Einfallswinkel. Ich habe eine Süd und einen West Kollektor, kann ich da einen Himmelsrichtung hinzufügen und was bringt mir das??
Kannst Du mir das Erklären!!
Danke
Gruß
Dirk

FrankB (Osterode) hat gesagt…

Hallo Guido,
hab die neue Version von Solstat installiert und leider einige Probleme.
Wenn Solstat startet will es zunächst das Setup durchlaufen !?
Wenn ich versuche, Farbeinstellungen zu ändern, werden diese nach dem Speichern nicht angenommen !?
Dies gilt auch für Kanalausblendungen !?
Bei den Auswertungen werden zwar Kanäle angezeigt, jedoch keine Werte eingetragen !?
Wo liegen die Probleme, was mach ich falsch !??
hArzlichen Gruß
frank

Guido (Brilon) hat gesagt…

Im SolStat.INI gibt es einen Schalter "_Setup done" - den auf 1 setzen und der Setup Dialog kommt nicht mehr beim Starten automatisch hoch.

Mir scheint SolStat kann in die INI nicht reinschreiben. Irgendetwas besonderes? VISTA etwa oder so einen Dreck ;-)

Erwin (Wildeck) hat gesagt…

Hallo Frank,

die alte SolStat.INI in den Ordner mit der neuen Version reinkopieren, die neue SolStat.INI dabei überschreiben. Der Name der neuen Version muß dabei aber wie der alte sein sonst in der SolStat.INI ändern, dann sollte es gehen.

Gruß, Erwin

FrankB (Osterode) hat gesagt…

Hi @Guido,
kein Vista; sondern XP
Hab @Erwins Rat befolgt (danke), nun geht (fast) alles ;-))

Allerdings hab ich immer noch das Problem, dass in der Ergebnisanzeige die Sensoren 1-14 ALLE ZU JEDER ZEIT 0,0°C anzeigen!?
Nur in der Spalte ENERGIE sind ALLE Werte auf -42,3 kWh gesetzt ????
Ich hab schon mehrere unterschiedliche Zeiträume ausgewählt; immer das gleiche Ergebnis; bin frustriert ;-((
da es ja bei @Erwin zu funktionieren scheint

Ist das wieder nur bei mir so ???

hArzlichst

Bernd hat gesagt…

Hallo Frank,

ich habe einfach die alte .ini ins neue Verzeichnis kopiert ohne weitere Änderungen daran zu machen. Bisher konnte ich keine Problem bezüglich der Anzeigen feststellen.
Sieht wohl eher nach einem Problem bei Dir am Rechner aus. Kann Dir gerne anbieten meine .ini zu probieren.

Grüße Bernd

Anonym hat gesagt…

Hallo @Bernd, es kann schon sein, dass es an meiner PC-Konfiguration liegt.
Gern nehm ich Dein Angebot an.
Bitte mailen an
info at fewo-balogh de
Ich geh mal davon aus, dass in Deine Ergebnisanzeige Werte eingetragen werden.

hArzliche Ostern
frankB (Osterode)

Anonym hat gesagt…

Hallo @Bernd, es kann schon sein, dass es an meiner PC-Konfiguration liegt.
Gern nehm ich Dein Angebot an.
Bitte mailen an
info at fewo-balogh de
Ich geh mal davon aus, dass in Deine Ergebnisanzeige Werte eingetragen werden.

hArzliche Ostern

Bernd hat gesagt…

Hallo Frank,
funktioniert meine INI-Datei bei Dir oder hast Du weiterhin die Probleme?
Grüße
Bernd

FrankB (Osterode) hat gesagt…

Hallo Bernd,

vielen Dank für Deine INI.
Inzwischen läuft alles wieder wie "vorher".
Alle Pfade sind angepasst und alle Profile werden angezeigt.
Auch Guiods Rätsel ist "gelöst"

Zwar weigert sich SolStat bei mir beim ersten Start weiterhin WinSol auszulesen, sodass es immer erst geschlossen, WinSol manuell gestartet und ausgelesen werden muß, um dann SolStat erneut zu starten, damit es dann die Daten ordnungsgemäß anzeigen kann.

Scheint aber ein Einzelproblem bei mir zu sein.

Vielen Dank Allen, die mit Rat und Tat beteiligt waren

hArzlichst
frank

Bernd hat gesagt…

Hallo Frank,

gern geschehen. Freut mich, wenn ich Dir weiterhelfen konnte.

Also ich lese die aktuellen Daten immer mit dem SolStat ComServer, findest Du auf der Homepage von Guido, aus. Die bereits gespeicherten daten kommen ja sowieso aus aus der Logdatei von Winsol. Das automatische Starten von Winsol aus SolStat hat bei mir auch nie wirklich funktioniert, also habe ich mir eine alternative gesucht.
Zur Datensicherung, also Download per Winsol, habe ich mir ein Script geschrieben, welches Winsol automatisch startet, die Daten holt und dann Winsol wieder beendet.
Dieses lasse ich zeitgesteuert alle 2 Stunden laufen und somit hätte ich auch keinen großen Datenverlust wenn mal der Strom ausfallen sollte.

Grüße
Bernd

Frank (Rödermark) hat gesagt…

Bei mir klappt der automatische Start von Winsol in 9 von 10 Fällen. Beim Anmelden bei Windows wird Solstat und der Com-Server über die Autostart-Gruppe automatisch gestartet, worauf Solstat die Daten von Winsol holt. In Solstat habe ich als Intervall "24 Stunden" eingegeben, weil es mir reicht, wenn Winsol nur beim Start von Solstat aufgerufen wird.

FrankB (Osterode) hat gesagt…

Hallo @Bernd,
auch bei mir werden SolStat und der ComServer via Autostart gestartet. SolStat sollte dann Winsol starten und die erforderlichen log-Daten auslesen. Dies geschieht leider nicht. Allerdings bin ich, wie ich jetzt weiss, nicht der einzige, bei dem es nicht oder nur bedingt klappt.

Bislang hab ich also Solstat geschlossen. WinSol manuell gestartet, die Daten ausgelesen, WinSol geschlossen und SolStat neu gestartet.
Solange ich zu Hause bin, ist das kein Problem, aber lästig.

Allerdings ist der Vorgang bislang nicht automatisierbar gewesen (auch wenn der PC mal einen "außerordentlichen Neustart" ausführte).

Insoweit wär ich an Deinem Script interessiert, wobei es mir ausreicht, wenn lediglich bei einem Neustart die log - Daten ausgelesen würden.

hArzlichst
frank

Helmut (Seligenstadt) hat gesagt…

Ich hatte das so gelöst, dass ich eine cmd-Datei geschrieben habe, in der zuerst Winsol und dann mit jeweils einer Verzögerung (bei mir 1 Minute) der Solstat-Server und zuletzt Solstat selbst gestartet wurde. Diesen Batch habe ich per Autostart gestartet.
In Solstat habe ich den automastischen Start von Winsol abgeschaltet.
Der Rechner wurde dann abends automatisch runtergefahren und per Zeitschaltuhr morgens wieder eingeschaltet. So habe ich die Daten per Winsol einmal am Tag ausgelesen - das hat bei mir wunderbar funktioniert (Trotz W2k... ;-).

ciao
helmut

Bernd hat gesagt…

Hallo Helmut,

wie ich lesen kann sind wir beide auf die selbe Idee gekommen ;-). Bei mir sind es mehrere einzelne Scripte, welche getrennt per Zeitschaltuhr (Timer) über den Tag verteilt ausgeführt werden.
Leider klappt bei mir der Neustart des Rechners am nächten Tag nicht wirklich und somit lasse ich diesen, bis ich das Problem gefunden gabe, durchlaufen. Sonst ist soweit als möglich alles automatisiert worden. Wie bzw. mit welchem Programm fährst Du den Rechner am Abend runter und startets diesen am nächsten Tag wieder?

Grüße
Bernd

Bernd hat gesagt…

Hallo Frank,

das Script habe ich Dir gestern geschickt, ich hoffe es hilft Dir weiter.

Gruß Bernd